おうまさん

SEのふりをしながら趣味をやる。

Premiere Pro 2.0が「Write_on_AEX」で起動しなくなった際の対処実績 (Windows10)

f:id:umauma2011:20190224162604j:plain

1. はじめに

Adobe Premiere Pro 2.0がWindows10で起動できない事象が発生した。起動の画面で「Write_on_AEX」が表示され、起動画面がまるごと落ちる事象となり、Premiere Pro自体が起動できない。

今回は、起動させるまでの対処法を実績として手順として示し、その他としてチェックポイントを挙げる。本記事で述べている内容で生じた問題には責任を取らないため、操作する際は事前に復元ポイントを作成するなど、ご注意願いたい。

 

使用OS : Windows10 Home 64bit Core i7-4700MQ メモリ : 8GB

 

2. 対処実績

ア) 「regedit」より、「コンピューター\HKEY_CURRENT_USER\Software\ASIO\ Premiere Pro Windows Sound」に存在する「Premiere Pro Windows Sound」を消去した(Premiere Pro Windows Soundのフォルダを消去すると、その配下のInputs,Outputsもついでに消える)。

レジストリを消去するため、注意して操作されたい。特に、Premiere側ではない通常の「Windows Sound」を絶対に消去しないように。

f:id:umauma2011:20190224165211p:plain

※ ア)を実施した後に、Adobe Premiere Pro 2.0のショートカットを右クリックから「管理者として実行」を押下し、起動が確認出来ない場合は、イ)へ進む。

 

イ) Adobe Premiere Pro 2.0をアンインストールした。

アンインストールする際は、環境設定ファイルを含めてPremiereソフト自体全て削除した(インストール先CドライブのPremiere Pro 2.0フォルダがまるごと無くなる状態)。

 

ウ) 「C:\adobe」フォルダを作成した。Cドライブ直下にadobeフォルダを作成し、そこにPremiere Pro 2.0をインストールするため。過去事例を探っていると、「Program Files(x86)」の「カッコx86」部分が悪さをしている情報があった。カッコが入っているとパスがソフト内でうまく読み取れない可能性があるというものであったため、カッコが含まれないインストール先のフォルダをCドライブ直下に作成した。

 

エ) Adobe Premiere Pro 2.0をインストールした。インストール先は、ウ)で作成したフォルダ「C:\adobe」を指定した。

※インストール先の指定はシリアル番号を入力した次あたり。初期がProgram Files(x86)となっている場合はもちろん変更する。

 

オ) インストール完了後、Adobe Premiere Pro 2.0のショートカットを右クリックし、「管理者として実行」を押下した。起動の際には、Write_on_AEXで一瞬止まるように見えたが、無事起動に成功した。また、ア)で消去した「コンピューター\HKEY_CURRENT_USER\Software\ASIO\ Premiere Pro Windows Sound」のフォルダが生成されていることを確認した。

 

以上の手順となる。OSの再起動は一度も行っていない。

 

3. その他の確認点や情報

・Write_on_AEXは、オーディオドライバ関連で落ちるという情報も見受けられる。上記で解決しなかった場合は、サウンド関連を疑うと良いかと思われる。

「コントロールパネル>ハードウェアとサウンドサウンド>再生」で不要と思われるドライバを無効としてみるなど。

 

・Write_on_AEX自体のファイルを消去しても効果はない。Write_on_AEXはAfter Effects系のファイルと言われているが、Cドライブ上にある「Write_on_AEX」を消去すると、次の別なAfter Effectsのファイルが呼ばれ、そこでまた落ちる。私は、Write_on_AEXが存在しているファイルを結局丸ごと消去したが、全く起動に結びつかず効果は無かった。

 

4. まとめ

今回は、Write_on_AEXでPremiere Pro 2.0が起動できなくなった際の対処実績を示した。Write_on_AEXは、上記にも述べたとおりオーディオ関連が原因となる場合が多いようで、特にオーディオでASIO関連を常日頃から触っている自分にとって「なにか不要なドライバを挿入してしまったか」等を考えたが、結局は「Program Files(x86)」のカッコが原因であり拍子抜けした。

同じような事象に悩まされている方向けに、情報共有できれば幸いである。